Logo
  Tuesday, August 4, 2020
Sign-In  |  Sign-Up  |  Contact Us  |  Bookmark 

Nuvi Wont start After Update to 2.6   
I just update my Nuvi 750 to v2.6 and now when i switch on the device its just gives a the boot screen and goes blank.. Did i do a mistake by updating it... plz can some1 help me fix it??? Thanks.....


Post Response 
kinkijo
03/10/2008
04:08:23 AM

dats wierd wat did you use to update the device, webupdater rite????
Post Reply

ritzie67
03/10/2008
04:12:55 AM

No i didnt i just went to the garmin website n updated the device here's the link i used
http://www8.garmin.com/support/download_details.jsp?id=3809
Post Reply

praldu
03/11/2008
07:27:30 AM

Did you disconnect the device properly afer updating ( Safely Remove Hardware Option)...
n did you give time once u updated the device... coz the update file of 2.6 is quite large n takes some time to install about 3-4min...
Post Reply

ritzie67
03/11/2008
07:29:09 AM

Yeah i safely remove it and started loading the update then it went black and i thought it went off so i turned it on... guess i actually turned if off thus interupting the update...
what can i do now to fix this prob?????
Post Reply

praldu
03/11/2008
07:29:52 AM

Try using the wepupdater and do the whole updating process all over again though it might take some time...
Post Reply

ritzie67
03/12/2008
01:15:47 AM

Yeah i wud do the same but the device just freezes on the boot screen when i connect it to the comp....freezes with garmin logo.....
Post Reply

durolex
03/12/2008
01:17:32 AM

Try a hard reset on the device if that doesnt work then i guess u'll have to contact the garmin Tech support.... might have to send ur device to them for reloading the software on it...
Post Reply

zamzam07
03/12/2008
04:27:43 AM

the same thing happened to me yesterday i updated the device from the web updater after disconnecting and switching it on it said "loading Software" for a min and then went black. Now it wont go past the boot screen contacted garmin and they have told me they are shipping me a new unit. said that my device is dead.
Post Reply

roingin
03/12/2008
04:30:26 AM

Wierd i too got the same problem after updating to 2.6 i called up garmin they cudnt do anythin so dey told me to send the device back to them....
Post Reply

avenue8
03/12/2008
05:45:19 AM

I spoke to the garmin tech support over the phone this is a known problem with the updater there's nothing to fix it they just get it replaced. and they have also told not to use the updater at this time as they are trying to correct the updater..
Post Reply

dcom
03/12/2008
05:48:53 AM

hey i just used the webupdater on my device and updated it works fine no problem at all.
Post Reply

ritzie67
03/12/2008
05:49:40 AM

Hey der if any1 manages to find a way to solve this prob without having to send it back plz lemme know thanks......
Post Reply

pryes
03/20/2008
04:05:23 AM

I used the webupdater on my device updated it.... it took some time to start the device after updating(3min) but works fine now....
Post Reply

1  |
Related Forums   
Download free us maps free for my TomTom one
Can someone please e mail me where I can download up to date us maps free to my TomTom one Thanks so much all the site ...
HTC S740 gets GPS support
I am big fan of HTC line of Windows Mobile phones. I just think that this company gets the market and delivers to the ...
adNav Boomerage is free GPS unit
Why pay $300 or more for GPS device when you can rent it. This is an iadea behind adNav Boomerage almost free GPS unit. ...
Treo 800w GPS Plugin
I just bought Treo 800w and I am looking ot purchase GPS Plugin for it. I heared that there is one and it works really ...
Nexusone Review
I am looking for nexusone review from third party site. It seems that there is a lot of Reviews but they are all ...
Nuvi 3760T Forum
Forum covering Nuvi 3760T GPS car model. People can post, share their experiences using Nuvi 3760T. It has good ...
More
Post Your Response
Your Name:*
LoginRegister
Subject:*
Type Message:*